Encrypted SSN Values Displayed in Data Connect and Partner Connect Tables

Incident Report for MeridianLink Statuspage

Identified

Data Connect clients can now rerun their pipelines to pull in decrypted SSNs. Our team is now working to implement a fix for Partner Connect.
Posted Jun 22, 2026 - 10:59 PDT

Investigating

Summary:
We are aware of an issue where some clients are seeing encrypted SSN values in various Data Connect and Partner Connect tables instead of the expected decrypted values. Our engineering team is actively investigating and working to restore normal behavior.

Impact:
Clients accessing SSN fields via Data Connect and Partner Connect may see encrypted values rather than decrypted values.

Current Status:
Our development team has identified the issue and is actively working on a resolution. We will provide updates as progress is made.
Posted Jun 22, 2026 - 08:00 PDT
This incident affects: Data and Partner Connect (Data Connect Operational Status, Partner Connect Operational Status).