CS - Server Latency

Incident Report for MeridianLink Statuspage

Resolved

After identifying an issue with lender2, which has since resolved itself, our Development team has observed that load times have returned to normal. If you have created a case with Support, could you please confirm that the system performance is now as expected?
Posted Apr 22, 2025 - 14:14 PDT

Monitoring

After identifying an issue with lender2, which has since resolved itself, our Development team has observed that load times have returned to normal. If you have created a case with Support, could you please confirm that the system performance is now as expected?
Posted Apr 22, 2025 - 12:02 PDT

Investigating

We are currently investigating this issue.
Posted Apr 22, 2025 - 11:35 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).