ML Consumer - Unable to Pull Credit

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jun 14, 2025 - 13:16 PDT

Monitoring

We received reports of user unable to pull credit.
The issue has been resolved and we have received confirmation from users that they are now able to pull credit.
Older applications may take some time to see the credit reports but new applications should function as normal.

We will continue to monitor the issue.
Posted Jun 14, 2025 - 11:29 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Credit Reports).