ML Consumer/Opening - PreciseID error

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 07:15 PST

Monitoring

Experian provided the following update:
We have started to see some alleviation, and our teams are actively working to ensure the issue is fully resolved.
Posted Feb 23, 2026 - 16:37 PST

Investigating

We are currently receiving reports of a PreciseID error that is preventing requests from being processed. Experian is experiencing technical issues on their end. We will provide updates as they become available.
Posted Feb 23, 2026 - 15:11 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Fraud Prevention Vendors).