ML Insight - Data Refresh Delay

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted May 16, 2025 - 06:11 PDT

Identified

We are currently experiencing a delay in our data refresh process. We estimate that the system will be fully updated within approximately 4 hours.

We sincerely apologize for any inconvenience this may cause to your daily operations and appreciate your patience as we work to resolve this issue.
Posted May 15, 2025 - 13:19 PDT

Investigating

We are investigating a delay in the data refresh for May 15, 2025.
Posted May 15, 2025 - 09:02 PDT
This incident affected: MeridianLink Insight (Data Refresh).