Salesforce Latency

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 06:55 PDT

Identified

We have identified the cause of the issue impacting our Resources Center (Client Portal) and confirmed it is related to a third‑party vendor dependency.

Our vendor partner is actively working on a resolution, and we are closely coordinating with them to support progress and minimize impact. This issue is impacting both Chat and Salesforce cases. We are currently experiencing latency and intermittent errors.

We will continue to share updates as we receive additional information.
Posted Sep 16, 2026 - 06:02 PDT
This incident affected: General (Global).