ML Consumer Clients Report Issues with TransUnion Credit Pulls

Incident Report for MeridianLink Statuspage

Resolved

This issue is confirmed to be resolved. Systems are all functioning normally.
Posted Mar 07, 2026 - 09:26 PST

Monitoring

TransUnion has made changes to address the issue. We are seeing applications processing normally now. We'll monitor for a bit to confirm that we don't see any continuing issues.
Posted Mar 07, 2026 - 09:11 PST

Identified

TransUnion is aware of an active incident and support teams are engaged and working towards resolution.
Posted Mar 07, 2026 - 08:56 PST

Investigating

We are currently investigating an issue being reporting by clients not being able to process TransUnion Credit Pulls. We will keep you update as we learn more via our investigation with TransUnion.
Posted Mar 07, 2026 - 07:26 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Credit Reports).