The fix has been deployed. Please confirm if performance has returned to normal for your users. If you have an open case, send us an update.
Posted May 28, 2026 - 13:14 PDT
Update
Our development team began deploying a fix to the Shared Production servers at 12 PM PT. We’ve started with WS and SECURE, followed by CS and ES. Each cluster will take approximately 15–20 minutes.
The remaining Shared Production servers will receive the fix after hours today, as only minimal impact has been reported on those environments.
No downtime is expected. Users may be signed out during deployment but can simply log back in.
Thank you for your patience as we work to resolve this issue.
Posted May 28, 2026 - 12:03 PDT
Update
We have identified the cause of the issue impacting fraud warning resolution and intermittent latency.
Our teams are actively working on a fix and are currently completing the build. Once finalized, we will proceed through testing and then deployment to production.
We will continue to provide updates as progress is made.
Posted May 28, 2026 - 10:32 PDT
Update
Our teams are actively working on a fix. Updated images are currently being built, after which we will deploy to testing and then move to production.
We are targeting approximately 90 minutes for full restoration, barring any unexpected issues.
We will continue to share updates as progress is made.
Posted May 28, 2026 - 09:11 PDT
Identified
We have identified the cause of the issue impacting fraud warning resolution.
Our teams are actively working on a fix.
We will continue to share updates as progress is made.
Posted May 28, 2026 - 08:30 PDT
Update
We are continuing to investigate reports of server latency affecting production.
Our teams remain actively engaged and are working to identify the underlying cause and fully understand the scope of impact. At this time, there is no change in status, but investigation efforts are ongoing and a high priority.
We will continue to share updates as additional information becomes available.
Posted May 28, 2026 - 06:47 PDT
Investigating
We are currently investigating reports of latency affecting production servers.
Our teams are actively reviewing the situation and working to better understand the scope. We will provide updates as additional information becomes available.