MLM - Webhook Event Integration Notification Delays

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 12:00 PST

Update

We are continuing to monitor for any further issues.
Posted Dec 12, 2025 - 10:18 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2025 - 20:17 PST

Identified

The issue has been identified, and a resolution is currently being implemented. New event notifications are processing as expected, and previously queued events are beginning to clear.
Posted Dec 11, 2025 - 19:49 PST

Investigating

We are currently investigating this issue.
Posted Dec 11, 2025 - 17:53 PST
This incident affected: MeridianLink Mortgage (Mortgage App Integrations).