Meridianlink Insight Consumer and Opening- Data Refresh Delay

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 05:51 PDT

Identified

Our team has identified the root cause of this morning’s data refresh delay affecting the Insight Consumer and Opening data source. We are actively deploying a fix and expect data refreshes to complete by 2:00 PM EST.

We sincerely apologize for the inconvenience this may cause and appreciate your patience as we work to restore normal processing.
Posted Apr 16, 2026 - 04:12 PDT
This incident affected: MeridianLink Insight (Data Refresh, Insight for Consumer and Opening).