ML Consumer/Opening - Latency on the LIVE server

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 18:30 PST

Update

System performance has returned to normal levels. Our technical team continues to monitor closely to maintain stability and ensure optimal performance.
Posted Jan 12, 2026 - 16:34 PST

Monitoring

We have received alerts of latency on the live.consumer server. Auto-scaling measures have been implemented, which have provided partial improvement. Our technical team is closely monitoring the situation and working to ensure optimal performance.
Posted Jan 12, 2026 - 15:21 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).