ML Collect - System Slowness

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 08:04 PDT

Investigating

ML Collect is experiencing system slowness currently. Our team is currently working to address the issue as quickly as possible.
Posted Jun 18, 2025 - 07:01 PDT
This incident affected: MeridianLink Collect (Collect App Operational Status).