MeridianLink PriceMyLoan: Ratesheet for PCB Wholesale is experiencing a processing delay

Incident Report for MeridianLink Statuspage

Resolved

This has been resolved.
Posted Apr 16, 2026 - 10:30 PDT

Investigating

The PriceMyLoan team is experiencing an issue with the PCB (Plains Commerce Bank) Wholesale rate sheet and has not yet been able to load those rates into PML. The team is working to resolve the issue.
Posted Apr 16, 2026 - 09:01 PDT
This incident affected: MeridianLink Mortgage Access (Mortgage Access), MeridianLink Mortgage OpenClose/Optics/CAW (OpenClose Pricing Engine (PriceMyLoan)), and MeridianLink Mortgage (Mortgage App Pricing Engine (PML)).