ML Insight - Data Refresh Delay - Large Clients Affected Only

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 11:10 PST

Identified

We’re applying the final fixes, and Insight should be refreshed within the next ~3 hours.
Posted Jan 29, 2026 - 07:21 PST

Investigating

We are investigating a delay in the data refresh for January 29, 2026. This is only affecting larger institutions on the platform; all other data points are refreshed for other clients.
Posted Jan 29, 2026 - 06:26 PST
This incident affected: MeridianLink Insight (Data Refresh).