Decision Lender 4 Production– Reports Sitting in a Queued Status

Incident Report for MeridianLink Statuspage

Resolved

This issue has been resolved and confirmed.
Posted May 19, 2026 - 07:35 PDT

Monitoring

A fix has been implemented, and report generation is now functioning as expected.
We are actively monitoring to ensure continued stability. We recommend submitting a new report to confirm successful processing.
Posted May 19, 2026 - 07:22 PDT

Identified

IT have identified the issue and recovered the database. Reports that were previously requested may have encountered errors; however, the issue has been resolved. New report requests should now generate successfully.
Posted May 19, 2026 - 07:21 PDT

Investigating

All reports requested today are currently stuck in a Queued (Runnable on batch) status and are not progressing to completion.
Posted May 19, 2026 - 07:13 PDT
This incident affected: MeridianLink DecisionLender (DecisionLender4 App Operational Status).