ML Consumer/Opening - CS and ES Server Latency Reports

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 16:33 PST

Monitoring

The CS and ES environments have been restored to normal. Our technical team is actively monitoring server health to ensure stability and prevent further issues.
Posted Nov 21, 2025 - 11:03 PST

Investigating

Clients are reporting experiencing intermittent slowness on both the CS and ES servers. We are currently looking into this on our end.
Posted Nov 21, 2025 - 09:22 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).