Encrypted SSN Values Displayed in Partner Connect Tables

Incident Report for MeridianLink Statuspage

Resolved

Partner Connect vendors are now able to see decrypted SSNs in the pipeline.
Posted Jun 23, 2026 - 13:49 PDT

Identified

Summary:
We are aware of an issue where some clients are seeing encrypted SSN values in various Partner Connect tables instead of the expected decrypted values. Our engineering team is actively investigating and working to restore normal behavior.
Posted Jun 23, 2026 - 13:35 PDT
This incident affected: Data and Partner Connect (Partner Connect Operational Status).