ML Insight - Data Refresh Delay

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 07:00 PDT

Investigating

We are investigating a delay in the data refresh for July 11, 2025. We apologize for any inconvenience this may have caused.

This is currently affecting both data sources (Insight Consumer and Opening, Insight Consumer Cube).
Posted Jul 11, 2025 - 06:55 PDT
This incident affected: MeridianLink Insight (Data Refresh).