PriceMyLoan Rates Delayed Today 7/1/2025

Incident Report for MeridianLink Statuspage

Resolved

PML Rates are up to date, this issue has been resolved.
Posted Jul 01, 2025 - 10:56 PDT

Identified

The PML team is now estimating that all rates will be updated in 30 minutes. Investor repricing could cause a delay beyond this.
Posted Jul 01, 2025 - 10:01 PDT

Investigating

The pricing engine, PriceMyLoan, is experiencing a delay in loading today's rate sheets. The team is working to expedite this issue. Once rates have been updated, we will inform you.
Posted Jul 01, 2025 - 09:10 PDT
This incident affected: MeridianLink Mortgage OpenClose/Optics/CAW (OpenClose), MeridianLink Mortgage Access (Mortgage Access), and MeridianLink Mortgage (Mortgage App Pricing Engine (PML)).