ML Consumer/Opening - Experian Precise ID Error

Incident Report for MeridianLink Statuspage

Resolved

All Experian Data Quality services are currently operational, as confirmed by https://status.edq.com/.
Posted Oct 30, 2025 - 08:04 PDT

Monitoring

Users are reporting receiving errors when retrieving Experian CrossCore / PreciseID responses.
It appears the Experian Data Quality services have been experiencing degraded performance issues as posted on https://status.edq.com/.
More information will be provided as it is available.
Posted Oct 29, 2025 - 14:30 PDT