MeridianLink PriceMyLoan ratesheet processing delays

Incident Report for MeridianLink Statuspage

Update

The rates team has successfully completed manual processing of today’s rates for all eligible rate sheets. Meanwhile, the engineering team is deploying a hotfix to restore the automated process. We will continue to keep you informed and will provide another update as soon as more details are available.
Posted Feb 25, 2026 - 14:17 PST

Update

The rates team has continued to process rates manually while the engineers are working to deploy a fix to the automated process. Progress is being made, and we will share another update once additional details are available.
Posted Feb 25, 2026 - 12:36 PST

Update

Our engineers are actively working on a fix to restore automated processing of rates and eliminate the need for manual handling. Progress is being made, and we will share another update once additional details are available.
Posted Feb 25, 2026 - 10:50 PST

Identified

The reason for the processing delay has been identified, so we are manually processing rates. Publishing of rates is currently a work in progress. As soon as we have more information, we will update you.
Posted Feb 25, 2026 - 09:23 PST

Investigating

The pricing engine, PriceMyLoan, is experiencing rate sheet processing delays. Our engineers are looking into the issue. This impacts rates for customers using pricing in the following products: MeridianLink Mortgage, Mortgage Access, OpenClose.
Posted Feb 25, 2026 - 08:18 PST
This incident affects: MeridianLink Mortgage OpenClose/Optics/CAW (OpenClose), MeridianLink Mortgage Access (Mortgage Access), and MeridianLink Mortgage (Mortgage App Pricing Engine (PML)).