ML Consumer/Opening - 3rd Party Integrations Using Cloudflare May See Disruptions in Services

Incident Report for MeridianLink Statuspage

Resolved

Latest update from Cloudflare - we will be marking this as resolved on our end:

Update - Cloudflare services are currently operating normally. We are no longer observing elevated errors or latency across the network.

Our engineering teams continue to closely monitor the platform and perform a deeper investigation into the earlier disruption, but no configuration changes are being made at this time.

At this point, it is considered safe to re-enable any Cloudflare services that were temporarily disabled during the incident. We will provide a final update once our investigation is complete.
Nov 18, 2025 - 17:44 UTC
Posted Nov 18, 2025 - 10:38 PST

Update

Latest updates from Cloudflare:

Update - We continue to see errors drop as we work through services globally and clearing remaining errors and latency.
Nov 18, 2025 - 16:46 UTC
Update - We continue to see errors and latency improve but still have reports of intermittent errors. The team continues to monitor the situation as it improves, and looking for ways to accelerate full recovery.
Nov 18, 2025 - 16:27 UTC
Posted Nov 18, 2025 - 09:00 PST

Monitoring

We are monitoring Cloudflare's site for status.
Posted Nov 18, 2025 - 06:56 PST

Investigating

Users are reporting issues with some integrations in our system and these integrations may be using Cloudflare.
Cloudflare has acknowledged the issue are and working to remedy it.

Side effects may be felt thru their full resolution.

https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 06:55 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App - Other Partner Integrations).