Custom & Standard Reports Stuck in Please Wait After Regenerating

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted May 16, 2025 - 13:57 PDT

Monitoring

Development has added a VM to help relieve the backlog and is currently monitoring the report processing. It will take a few minutes to work through the backlog. If you have opened a case with Support, please update the case and let us know if the reports are working as expected.
Posted May 16, 2025 - 10:57 PDT

Investigating

We are currently investigating this issue.
Posted May 16, 2025 - 09:56 PDT
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Reports).