MeridianLink Support Portal - Error Accessing From Product

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 11:03 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2025 - 08:23 PDT

Identified

We have received reports of certain users unable access to the MeridianLink Support Portal from within the MeridianLink product. Users receive an error message stating "URL No Longer Exists." Our team is aware of the issue and is working with our vendor partner to resolve it.
Posted Jun 16, 2025 - 15:40 PDT
This incident affected: MeridianLink Mortgage Credit Link (Mortgage Credit Link App Operational Status) and TazWorks (InstaScreen Operational Status).