TazWorks - i3screen Drug Screen Ordering Outage
Incident Report for MeridianLink Statuspage
Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 22:14 PST
Update
We are still no longer experiencing errors related to i3screen orders. We are currently monitoring to ensure the issue is fully resolved.
Posted Jan 26, 2023 - 15:14 PST
Monitoring
We are no longer experiencing errors related to i3screen orders. We are currently monitoring to ensure the issue is fully resolved.
Posted Jan 26, 2023 - 13:01 PST
Investigating
We are currently investigating the error we are receiving with i3screen orders: "Error With I3screen Order creation. I3Screen Order Not Created" and will update you once we find out more about the cause.
Posted Jan 26, 2023 - 09:23 PST
This incident affected: TazWorks (InstaScreen Partner Integrations).