TazWorks: The Work Number Connectivity Issue

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Sep 27, 2023 - 07:25 PDT

Identified

The issue with The Work Number integration has been identified, and a fix is currently being worked on.
Posted Sep 26, 2023 - 15:25 PDT

Investigating

The Work Number integration is currently not functioning properly. We have reached out to our contact at Equifax and are awating a response. Please reach out to The Work Number for updates.
Posted Sep 26, 2023 - 09:09 PDT
This incident affected: TazWorks (InstaScreen Partner Integrations).