Mortgage Credit Link (MCL) - Equifax is Down, returning "Fico not available" or "Bureau is currently unavailable" errors.
Incident Report for MeridianLink Statuspage
Resolved
Equifax connection is restored and this is considered resolved.
Posted Apr 19, 2024 - 07:51 PDT
Monitoring
Scores appear to be coming through now from Equifax. Will continue to monitor the rest of today.
Posted Apr 18, 2024 - 11:52 PDT
Investigating
Equifax began returning errors this morning around 11:45am, including "FICO NOT AVAILABLE" or "Bureau is currently unavailable". We are reaching out to Equifax to alert them of this outage, which appears to be a connection down on their end.
Posted Apr 18, 2024 - 09:35 PDT
This incident affected: MeridianLink Mortgage Credit Link (Mortgage Credit Link App Operational Status).