TazWorks - Insights Offline
Incident Report for MeridianLink Statuspage
Resolved
TazWorks Insights is now back online and available, and we have communicated directly with CRAs utilizing the product. Thank you for your patience.
Posted Apr 16, 2024 - 15:18 PDT
Identified
TazWorks Insights reporting is currently offline and unavailable. We will share additional information with impacted CRAs as we receive it.
Posted Apr 15, 2024 - 14:35 PDT
This incident affected: TazWorks (InstaScreen Operational Status).