ML Consumer/Opening - Experian PID/Cross Core Timeout Errors

Incident Report for MeridianLink Statuspage

Resolved

Clients have confirmed the issues are resolved.
Posted Nov 03, 2025 - 12:30 PST

Monitoring

Experian has confirmed that the issues should be resolved. Will we monitor for client confirmations.
Posted Nov 03, 2025 - 12:04 PST

Identified

We have reached out to Experian directly who acknowledged that they are working to resolve this issue.

INC11746569 has been opened by Experian to resolve the issue.

We will advise when we receive more details from their team.
Posted Nov 03, 2025 - 08:13 PST

Investigating

We are currently investigating this issue.
Posted Nov 03, 2025 - 08:00 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Credit Reports, Consumer App - Other Partner Integrations).