ML Consumer/Opening - Latency on Secure

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 19:07 PST

Monitoring

The development team has resolved the issue. If you have an open support case, please confirm whether the resolution addresses your concern.
Posted Nov 10, 2025 - 14:11 PST

Investigating

The Secure.consumer.meridianlink.com environment is experiencing latencies.
Our technical team is investigating the issue.
Posted Nov 10, 2025 - 12:33 PST
This incident affected: MeridianLink Consumer / MeridianLink Opening (Consumer App Operational Status).