PriceMyLoan Rates Delayed Today 11/4/2025 from some Investors, on some Loan Programs

Incident Report for MeridianLink Statuspage

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 09:54 PST

Investigating

The pricing engine, PriceMyLoan, is experiencing a delay in loading some of today's rate sheets from some investors, impacting pricing some loan programs. The team is working to expedite this issue. Once all rates have been updated, we will inform you.
Posted Nov 04, 2025 - 08:33 PST
This incident affected: MeridianLink Mortgage OpenClose/Optics/CAW (OpenClose), MeridianLink Mortgage Access (Mortgage Access), and MeridianLink Mortgage (Mortgage App LOS, Mortgage App Pricing Engine (PML)).